summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:06:22 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:38:20 +0300
commitb2eeca763255e42c7f4d4984805ac3c4ee023408 (patch)
tree0780362c1dd7f23f4fcccde6d5647c7904c281f8 /dev-python/pyroute2
parentapp-admin/awscli: add 1.25.71 (diff)
downloadgentoo-b2eeca763255e42c7f4d4984805ac3c4ee023408.tar.gz
gentoo-b2eeca763255e42c7f4d4984805ac3c4ee023408.tar.bz2
gentoo-b2eeca763255e42c7f4d4984805ac3c4ee023408.zip
dev-python/pyroute2: add 0.7.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
index 2e397ebdeb8f..2b2333f30f18 100644
--- a/dev-python/pyroute2/Manifest
+++ b/dev-python/pyroute2/Manifest
@@ -1 +1,2 @@
DIST pyroute2-0.7.2.gh.tar.gz 469459 BLAKE2B 06aa7640bb21c0a7b8035723069d78b28ca39b554b5bdc0a031dbc7376251265b118b222cb4283156c02136e63de4b77103c02a88b700ac5f49fa8ceac28528a SHA512 6c032b39675d539958642bb16b3b964e78613cdd2d49e2e206a13d5256872e3800de5c73cff761e4a756d31df0e07f18f08d193a0543c87be89da348662e6dbd
+DIST pyroute2-0.7.3.gh.tar.gz 484152 BLAKE2B 4f0cd0fc000c7bd3baffaa2ed25468bc28806fef2f9bc96e39606afe46e616d85865f497df6d1e3e4b2e5e3956b5fca22af273140bbb38954c6f0c0f86c386a6 SHA512 c8aeddaeaa014bcf8c4b831cb5b4080db5c99b582f3999fdbdd840b9448e032fbbf64ce5707ebc0795765138d8e89cde830efb2469c827ed8d4e63dd1beafe62
diff --git a/dev-python/pyroute2/pyroute2-0.7.3.ebuild b/dev-python/pyroute2/pyroute2-0.7.3.ebuild
new file mode 100644
index 000000000000..791e7e0b54d8
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8,9,10} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="https://github.com/svinota/pyroute2"
+
+SRC_URI="
+ https://github.com/svinota/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+# tests need root access
+RESTRICT="test"