summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-07 11:38:22 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-07 13:00:00 +0100
commit2e4bf39787b497e995bdc29c0ecabefc14e5c009 (patch)
tree8dda054d0d211ede90e06278cdb01081c8198322 /dev-python/pyrsistent/pyrsistent-0.11.12.ebuild
parentdev-python/nose-show-skipped: New package, ebuild written by me (diff)
downloadgentoo-2e4bf39787b497e995bdc29c0ecabefc14e5c009.tar.gz
gentoo-2e4bf39787b497e995bdc29c0ecabefc14e5c009.tar.bz2
gentoo-2e4bf39787b497e995bdc29c0ecabefc14e5c009.zip
dev-python/pyrsistent: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyrsistent/pyrsistent-0.11.12.ebuild')
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.11.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/pyrsistent-0.11.12.ebuild b/dev-python/pyrsistent/pyrsistent-0.11.12.ebuild
new file mode 100644
index 000000000000..f45f4f98fb76
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.11.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="http://github.com/tobgu/pyrsistent/ http://pypi.python.org/pypi/pyrsistent"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# https://github.com/tobgu/pyrsistent/issues/
+# fails
+#RESTRICT="test"
+
+python_test() {
+ export PYTHONPATH="${S}:${PYTHONPATH}"
+ py.test -v -v -x || die ${PYTHONPATH}
+}