summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-11-18 16:14:27 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-11-18 16:23:01 -0600
commitf155efca3b34d69ca0fccfcee198055d3caca26d (patch)
tree5c8d1413fd136783578b963e0be4239083571084 /dev-python/pysaml2/pysaml2-4.5.0.ebuild
parentsys-apps/haveged: fix Manifest, bug #637982 (diff)
downloadgentoo-f155efca3b34d69ca0fccfcee198055d3caca26d.tar.gz
gentoo-f155efca3b34d69ca0fccfcee198055d3caca26d.tar.bz2
gentoo-f155efca3b34d69ca0fccfcee198055d3caca26d.zip
dev-python/pysaml2: bup to 4.5.0
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-python/pysaml2/pysaml2-4.5.0.ebuild')
-rw-r--r--dev-python/pysaml2/pysaml2-4.5.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pysaml2/pysaml2-4.5.0.ebuild b/dev-python/pysaml2/pysaml2-4.5.0.ebuild
new file mode 100644
index 000000000000..651a17f3dedb
--- /dev/null
+++ b/dev-python/pysaml2/pysaml2-4.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of SAML Version 2 to be used in a WSGI environment"
+HOMEPAGE="https://github.com/rohe/pysaml2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+PATCHES=(
+
+)
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"