summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-12-30 19:32:15 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2018-12-30 19:32:33 +0200
commit5146ffa4f45a202a5551fa987bd57ba7770c959d (patch)
tree4e775326a76f556dd116832dfb17eb9748a3423f /dev-python/pyscard/pyscard-1.9.7.ebuild
parentsys-apps/pcsc-lite: version bump (diff)
downloadgentoo-5146ffa4f45a202a5551fa987bd57ba7770c959d.tar.gz
gentoo-5146ffa4f45a202a5551fa987bd57ba7770c959d.tar.bz2
gentoo-5146ffa4f45a202a5551fa987bd57ba7770c959d.zip
dev-python/pyscard: version bump
Closes: https://bugs.gentoo.org/show_bug.cgi?id=674054 Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/pyscard/pyscard-1.9.7.ebuild')
-rw-r--r--dev-python/pyscard/pyscard-1.9.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyscard/pyscard-1.9.7.ebuild b/dev-python/pyscard/pyscard-1.9.7.ebuild
new file mode 100644
index 000000000000..f0560bcd991c
--- /dev/null
+++ b/dev-python/pyscard/pyscard-1.9.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Smart cards support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="${PYTHON_DEP}
+ sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${PYTHON_DEP}
+ dev-lang/swig"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/pyro
+}