summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-23 08:29:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-23 10:16:13 +0200
commit1a8c766db3dba05220d685af8e45b29031aaa734 (patch)
tree0d6af8776c72acfd13608f121b9bce3bb25a5f87 /dev-python/pyscard
parentdev-python/flask-security: Bump to 4.1.2 (diff)
downloadgentoo-1a8c766db3dba05220d685af8e45b29031aaa734.tar.gz
gentoo-1a8c766db3dba05220d685af8e45b29031aaa734.tar.bz2
gentoo-1a8c766db3dba05220d685af8e45b29031aaa734.zip
dev-python/pyscard: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyscard')
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.0.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 851faa787244..da1036fb29a4 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-2.0.1.tar.gz 149193 BLAKE2B f140e3e62635634de8125d88c69e4ac3657468eef04798b4ce5b20d73905189ced71f041ef7742233a185aff8b28cc0fcda5af175d6dff21afeff84f062afcce SHA512 c9292b9616f150e500b308c47b0d6ed6f869f2022149c99a7789f8fef8c145dec4db84d35b6df30fa31d4007dffff75fcc21c9846693eccd9bd3bc8ec77fce5a
+DIST pyscard-2.0.2.tar.gz 149302 BLAKE2B bb1203aea42a0caca5212780f1312e51a4cf1a2b2842e3e33f25c17e57e3400d44c387620ec4a1dc9ca7a4ef5747900981971c87d1e37b6523a5990362645f5a SHA512 f6ab42a0aa037189f2fefe4001dde7f49125fdf63358352af956e58da9a51744a884ff1f7173b71e035a1a4a20825a906ee5d94f314b760333d1110c898a6644
diff --git a/dev-python/pyscard/pyscard-2.0.2.ebuild b/dev-python/pyscard/pyscard-2.0.2.ebuild
new file mode 100644
index 000000000000..3ca571fac574
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND="sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig"
+
+distutils_enable_tests setup.py
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}