summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-10-19 22:18:20 +0200
committerMichał Górny <mgorny@gentoo.org>2017-10-19 22:22:28 +0200
commitf21ce9b294121566ad04c1708171950e0956b550 (patch)
treea8bcc7ef03563ac5b226cedceb9ea548e4933599 /dev-python/pysha3/pysha3-1.0.2.ebuild
parentsci-mathematics/why3-for-spark: Adding why3 for spark (diff)
downloadgentoo-f21ce9b294121566ad04c1708171950e0956b550.tar.gz
gentoo-f21ce9b294121566ad04c1708171950e0956b550.tar.bz2
gentoo-f21ce9b294121566ad04c1708171950e0956b550.zip
dev-python/pysha3: New package
Add the backport of SHA3 hash functions for Python < 3.6, it is the most lightweight provider of the hash for Portage.
Diffstat (limited to 'dev-python/pysha3/pysha3-1.0.2.ebuild')
-rw-r--r--dev-python/pysha3/pysha3-1.0.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pysha3/pysha3-1.0.2.ebuild b/dev-python/pysha3/pysha3-1.0.2.ebuild
new file mode 100644
index 000000000000..2f9172ea7855
--- /dev/null
+++ b/dev-python/pysha3/pysha3-1.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="SHA-3 (Keccak) for Python 2.7 - 3.5"
+HOMEPAGE="https://github.com/tiran/pysha3 https://pypi.python.org/pypi/pysha3"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0 PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}