summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyside-tools/pyside-tools-0.2.15-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyside-tools/pyside-tools-0.2.15-r1.ebuild')
-rw-r--r--dev-python/pyside-tools/pyside-tools-0.2.15-r1.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pyside-tools/pyside-tools-0.2.15-r1.ebuild b/dev-python/pyside-tools/pyside-tools-0.2.15-r1.ebuild
new file mode 100644
index 000000000000..64c5ceb94912
--- /dev/null
+++ b/dev-python/pyside-tools/pyside-tools-0.2.15-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CMAKE_IN_SOURCE_BUILD="1"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+VIRTUALX_COMMAND="cmake-utils_src_test"
+
+inherit eutils cmake-utils python-r1 vcs-snapshot virtualx
+
+DESCRIPTION="PySide development tools (lupdate, rcc, uic)"
+HOMEPAGE="http://qt-project.org/wiki/PySide"
+SRC_URI="https://github.com/PySide/Tools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyside-1.2.0[X,${PYTHON_USEDEP}]
+ >=dev-python/shiboken-1.2.0[${PYTHON_USEDEP}]
+ >=dev-qt/qtcore-4.7.0:4
+ >=dev-qt/qtgui-4.7.0:4
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ test? ( virtual/pkgconfig )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0.2.13-fix-pysideuic-test-and-install.patch
+
+ python_copy_sources
+
+ preparation() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+ if python_is_python3; then
+ rm -fr pysideuic/port_v2
+ else
+ rm -fr pysideuic/port_v3
+ fi
+
+ sed -i -e "/pkg-config/ s:shiboken:&-${EPYTHON}:" \
+ tests/rcc/run_test.sh || die
+ popd >/dev/null || die
+ }
+ python_foreach_impl preparation
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ -DPYTHON_BASENAME="-${EPYTHON}"
+ -DPYTHON_SUFFIX="-${EPYTHON}"
+ $(cmake-utils_use_build test TESTS)
+ )
+ CMAKE_USE_DIR="${BUILD_DIR}" cmake-utils_src_configure
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ compilation() {
+ CMAKE_USE_DIR="${BUILD_DIR}" cmake-utils_src_make
+ }
+ python_foreach_impl compilation
+}
+
+src_test() {
+ testing() {
+ CMAKE_USE_DIR="${BUILD_DIR}" virtualmake
+ }
+ python_foreach_impl testing
+}
+
+src_install() {
+ installation() {
+ CMAKE_USE_DIR="${BUILD_DIR}" cmake-utils_src_install DESTDIR="${D}"
+ }
+ python_foreach_impl installation
+
+ dodoc AUTHORS
+}