summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-05 15:23:59 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-05 15:53:00 +0200
commitb159d3f9268bd77e7ab821c8336c967f5413dadc (patch)
tree4c99906b6200a65326dd2c36f0c7d653402df6fa /dev-python/pysmi/pysmi-0.3.1.ebuild
parentdev-python/scandir: version bump. (diff)
downloadgentoo-b159d3f9268bd77e7ab821c8336c967f5413dadc.tar.gz
gentoo-b159d3f9268bd77e7ab821c8336c967f5413dadc.tar.bz2
gentoo-b159d3f9268bd77e7ab821c8336c967f5413dadc.zip
dev-python/pysmi: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/pysmi/pysmi-0.3.1.ebuild')
-rw-r--r--dev-python/pysmi/pysmi-0.3.1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/pysmi/pysmi-0.3.1.ebuild b/dev-python/pysmi/pysmi-0.3.1.ebuild
new file mode 100644
index 000000000000..c583f95f2379
--- /dev/null
+++ b/dev-python/pysmi/pysmi-0.3.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2017-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python Lex & Yacc"
+HOMEPAGE="https://github.com/etingof/pysmi"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"