summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2019-12-18 19:12:22 +0100
committerConrad Kostecki <conikost@gentoo.org>2019-12-18 19:17:58 +0100
commitb849d08770a7b44a790313d8ff9fdb5a5baac15a (patch)
tree5844fd967bec379e85fe146e050061a63d3b78ee /dev-python/pyspectrum2
parentnet-im/yowsup: bump to version 3.2.3_p20190905 (diff)
downloadgentoo-b849d08770a7b44a790313d8ff9fdb5a5baac15a.tar.gz
gentoo-b849d08770a7b44a790313d8ff9fdb5a5baac15a.tar.bz2
gentoo-b849d08770a7b44a790313d8ff9fdb5a5baac15a.zip
dev-python/pyspectrum2: New package
Will be needed as a new dependency for python3-enabled net-im/transwhat. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/pyspectrum2')
-rw-r--r--dev-python/pyspectrum2/Manifest1
-rw-r--r--dev-python/pyspectrum2/metadata.xml16
-rw-r--r--dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild26
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyspectrum2/Manifest b/dev-python/pyspectrum2/Manifest
new file mode 100644
index 000000000000..805d7ac78469
--- /dev/null
+++ b/dev-python/pyspectrum2/Manifest
@@ -0,0 +1 @@
+DIST pyspectrum2-0.2.0.tar.gz 31500 BLAKE2B 230329f9b1f12c7f7cff234b95d9715609cd0922c6c833726dfe72e7da0ba646e8d059d2f42d70fb97c8cb755436307369336551d44bf7954f2281f49d03ea6f SHA512 40c9f7dda808fd5bca05026b7418022b660d53b6ef52d684885ed04a47185ce2d1e2988bff5b874977c736bf5cf75f10f9daf752475504327844d4f1948f2286
diff --git a/dev-python/pyspectrum2/metadata.xml b/dev-python/pyspectrum2/metadata.xml
new file mode 100644
index 000000000000..a7931bdfa4ff
--- /dev/null
+++ b/dev-python/pyspectrum2/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ pyspectrum2 implements the Protobuf-based interface to Spectrum2
+ required for building Python-based Spectrum2 backends.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/stv0g/pyspectrum2/issues</bugs-to>
+ <remote-id type="github">stv0g/pyspectrum2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild b/dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild
new file mode 100644
index 000000000000..162ca0316ca4
--- /dev/null
+++ b/dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a protobuf-based interface for Spectrum2 python-based backends"
+HOMEPAGE="https://github.com/stv0g/pyspectrum2"
+SRC_URI="https://github.com/stv0g/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/protobuf-python[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ python_optimize
+}