summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pysrt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/Manifest3
-rw-r--r--dev-python/pysrt/metadata.xml12
-rw-r--r--dev-python/pysrt/pysrt-0.5.1.ebuild43
-rw-r--r--dev-python/pysrt/pysrt-1.0.0.ebuild37
-rw-r--r--dev-python/pysrt/pysrt-1.0.1.ebuild37
-rw-r--r--dev-python/pysrt/pysrt-9999.ebuild34
6 files changed, 166 insertions, 0 deletions
diff --git a/dev-python/pysrt/Manifest b/dev-python/pysrt/Manifest
new file mode 100644
index 000000000000..8b36024dad5c
--- /dev/null
+++ b/dev-python/pysrt/Manifest
@@ -0,0 +1,3 @@
+DIST pysrt-0.5.1.tar.gz 95486 SHA256 6de1d10c37f40272657eeb59b0911e27111a98957807ce7becef0e82cb738d53 SHA512 87544a1802c86543bad946d298e32b9e1474a0c6330686c3cea1b7c1b5dc948c4a0c15cd96fd65b8bf8a5d53993f5c416c4bb96a0c7c218b80abb47872e85486 WHIRLPOOL 166161d449729a351354a3ac80758bc0c0eea4d91431d95534dd7a41e36b3c2287555cee7b4e1c435122258da15588ee93ba920f4f9b8cc518e36d8f205009ff
+DIST pysrt-1.0.0.tar.gz 11966 SHA256 88b4f93223c84aa86741387dcf5bcec86acf961eb66383c4ba86b1ffbb826a64 SHA512 92aff2d30c0ff900f7fd4599bdcb666cf212d54a61ebf0b6d4c95699c15d0259cadf216a851ec9daad102bd70b097c878b05a259dcf89cb81d8f1f79631363ad WHIRLPOOL 1c4bd8df2b7f53289aa0b1684b7abc8a440ed3a2ada9e1473064ad288f3eb9b9b7b0cd359574cb2371299c964351c2c0696d2a4666c0522c799926d509cfb812
+DIST pysrt-1.0.1.tar.gz 11741 SHA256 5300a1584c8d15a1c49ef8880fa1ef7a4274ce3f24dde83ad581d12d875f6784 SHA512 cd03d40ebef953d7ea67073a114f10a87eb142670ece727d09a31b498835d8485ac0c125f4281b6ababdd6f0757f9549ce38cb05eda79b23ff17950ab891d0eb WHIRLPOOL f7629430ac7ee9b2a69d5618346e2f97f01a68683e8b9ef8c13519a87a7043852c142ba050b338ddccc992c4ada01bbae41b9d2bab2696cdb0fdc50761d7dd81
diff --git a/dev-python/pysrt/metadata.xml b/dev-python/pysrt/metadata.xml
new file mode 100644
index 000000000000..d6dd2b40ebbc
--- /dev/null
+++ b/dev-python/pysrt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nikoli@gmx.us</email>
+ </maintainer>
+ <herd>proxy-maintainers</herd>
+ <upstream>
+ <remote-id type="pypi">pysrt</remote-id>
+ <remote-id type="github">byroot/pysrt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pysrt/pysrt-0.5.1.ebuild b/dev-python/pysrt/pysrt-0.5.1.ebuild
new file mode 100644
index 000000000000..ae787dcd08d5
--- /dev/null
+++ b/dev-python/pysrt/pysrt-0.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.python.org/pypi/pysrt"
+# does not have tests/static/ # SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/byroot/pysrt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/charade[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+),${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=pysrt \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+src_install() {
+ rm -rf "${S}/tests" || die
+
+ distutils-r1_src_install
+}
+
+python_install() {
+ rm -rf "${BUILD_DIR}/lib/tests" || die
+
+ distutils-r1_python_install
+}
diff --git a/dev-python/pysrt/pysrt-1.0.0.ebuild b/dev-python/pysrt/pysrt-1.0.0.ebuild
new file mode 100644
index 000000000000..aa5f07d4d3af
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.python.org/pypi/pysrt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/charade[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+),${PYTHON_USEDEP}] )
+"
+
+# https://github.com/byroot/pysrt/issues/42
+RESTRICT="test"
+
+src_test() {
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ nosetests --with-coverage --cover-package=pysrt \
+ || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/pysrt/pysrt-1.0.1.ebuild b/dev-python/pysrt/pysrt-1.0.1.ebuild
new file mode 100644
index 000000000000..2c3b4884d4d8
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.python.org/pypi/pysrt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+),${PYTHON_USEDEP}] )
+"
+
+# https://github.com/byroot/pysrt/issues/42
+RESTRICT="test"
+
+src_test() {
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ nosetests --with-coverage --cover-package=pysrt \
+ || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/pysrt/pysrt-9999.ebuild b/dev-python/pysrt/pysrt-9999.ebuild
new file mode 100644
index 000000000000..9c1a0c109f07
--- /dev/null
+++ b/dev-python/pysrt/pysrt-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.python.org/pypi/pysrt"
+EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+),${PYTHON_USEDEP}] )
+"
+
+src_test() {
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ nosetests --with-coverage --cover-package=pysrt \
+ || die "Tests failed under ${EPYTHON}"
+}