summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-02 18:58:57 +0000
committerSam James <sam@gentoo.org>2020-08-02 18:58:57 +0000
commitcfbde63a68d4ba89cfaa23d3a8cf4d6edb69f0eb (patch)
treeee54e19dd7828b5adaa82566bf65eba462fd5ca3 /dev-python/pysrt
parentdev-python/dogpile-cache: add Python 3.9 (diff)
downloadgentoo-cfbde63a68d4ba89cfaa23d3a8cf4d6edb69f0eb.tar.gz
gentoo-cfbde63a68d4ba89cfaa23d3a8cf4d6edb69f0eb.tar.bz2
gentoo-cfbde63a68d4ba89cfaa23d3a8cf4d6edb69f0eb.zip
dev-python/pysrt: add Python 3.9
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/pysrt-1.1.2.ebuild14
-rw-r--r--dev-python/pysrt/pysrt-9999.ebuild14
2 files changed, 4 insertions, 24 deletions
diff --git a/dev-python/pysrt/pysrt-1.1.2.ebuild b/dev-python/pysrt/pysrt-1.1.2.ebuild
index e72f359339d2..4dc902e8279c 100644
--- a/dev-python/pysrt/pysrt-1.1.2.ebuild
+++ b/dev-python/pysrt/pysrt-1.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -20,17 +20,7 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-python_test() {
- nosetests -v || die "Tests failed under ${EPYTHON}"
-}
+distutils_enable_tests nose
diff --git a/dev-python/pysrt/pysrt-9999.ebuild b/dev-python/pysrt/pysrt-9999.ebuild
index 98e0450016cf..c6b6da91f0de 100644
--- a/dev-python/pysrt/pysrt-9999.ebuild
+++ b/dev-python/pysrt/pysrt-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -20,17 +20,7 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-python_test() {
- nosetests -v || die "Tests failed under ${EPYTHON}"
-}
+distutils_enable_tests nose