summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-09 16:03:28 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-09 16:10:02 +0100
commitf875093aef75b80cae6d6de6ea7d14b2c0c6c4e9 (patch)
tree517230b6f189820fb404612079d4ccbb08ca966e /dev-python/pystache/pystache-0.5.4.ebuild
parentdev-python/blinker: Readd doc USE handling (diff)
downloadgentoo-f875093aef75b80cae6d6de6ea7d14b2c0c6c4e9.tar.gz
gentoo-f875093aef75b80cae6d6de6ea7d14b2c0c6c4e9.tar.bz2
gentoo-f875093aef75b80cae6d6de6ea7d14b2c0c6c4e9.zip
dev-python/pystache: Add python3.5 support
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pystache/pystache-0.5.4.ebuild')
-rw-r--r--dev-python/pystache/pystache-0.5.4.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/pystache/pystache-0.5.4.ebuild b/dev-python/pystache/pystache-0.5.4.ebuild
index b8a098f62723..138efcffcdfe 100644
--- a/dev-python/pystache/pystache-0.5.4.ebuild
+++ b/dev-python/pystache/pystache-0.5.4.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
inherit distutils-r1
DESCRIPTION="Mustache for Python"
@@ -22,7 +23,6 @@ DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
- pushd "${BUILD_DIR}"/lib > /dev/null
- nosetests || die
- popd > /dev/null
+ cd "${BUILD_DIR}"/lib || die
+ nosetests --verbose || die
}