summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPoncho <poncho@spahan.ch>2019-12-11 08:48:50 +0100
committerAaron Bauman <bman@gentoo.org>2019-12-12 14:24:56 -0500
commitbe55cb56bf3a702a20cfe45113e0ef961eddab70 (patch)
tree056909b036bef3a43723136ab8ad6a4cc5b9da3c /dev-python/pysvg/pysvg-0.2.2_p3.ebuild
parentapp-doc/doxygen: fix git build dep; synchronize live ebuild (diff)
downloadgentoo-be55cb56bf3a702a20cfe45113e0ef961eddab70.tar.gz
gentoo-be55cb56bf3a702a20cfe45113e0ef961eddab70.tar.bz2
gentoo-be55cb56bf3a702a20cfe45113e0ef961eddab70.zip
dev-python/pysvg: version bump, add python3 support
Closes: https://bugs.gentoo.org/702518 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Daniel Brandt <poncho@spahan.ch> Closes: https://github.com/gentoo/gentoo/pull/13943 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/pysvg/pysvg-0.2.2_p3.ebuild')
-rw-r--r--dev-python/pysvg/pysvg-0.2.2_p3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pysvg/pysvg-0.2.2_p3.ebuild b/dev-python/pysvg/pysvg-0.2.2_p3.ebuild
new file mode 100644
index 000000000000..31a5ef344da1
--- /dev/null
+++ b/dev-python/pysvg/pysvg-0.2.2_p3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="${PN}-py3"
+MY_PV="${PV/_p/.post}"
+
+DESCRIPTION="Python SVG document creation library"
+HOMEPAGE="https://github.com/alorence/pysvg-py3"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"