summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-29 07:51:18 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-29 09:30:01 +0100
commit152b16d4448c869fca0b56d946aa4b1ebe6b1eca (patch)
tree64bd3e4aa847f5e18bbe871694538d5033b436ff /dev-python/pytables/pytables-3.7.0.ebuild
parentdev-python/pytables: Revert "add 3.7.0" (diff)
downloadgentoo-152b16d4448c869fca0b56d946aa4b1ebe6b1eca.tar.gz
gentoo-152b16d4448c869fca0b56d946aa4b1ebe6b1eca.tar.bz2
gentoo-152b16d4448c869fca0b56d946aa4b1ebe6b1eca.zip
dev-python/pytables: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytables/pytables-3.7.0.ebuild')
-rw-r--r--dev-python/pytables/pytables-3.7.0.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/pytables/pytables-3.7.0.ebuild b/dev-python/pytables/pytables-3.7.0.ebuild
new file mode 100644
index 000000000000..dd909e6784ab
--- /dev/null
+++ b/dev-python/pytables/pytables-3.7.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+MY_PN=tables
+MY_P=${MY_PN}-${PV}
+inherit distutils-r1
+
+DESCRIPTION="Hierarchical datasets for Python"
+HOMEPAGE="https://www.pytables.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-arch/bzip2:0=
+ app-arch/lz4:0=
+ >=app-arch/zstd-1.0.0:=
+ >=dev-libs/c-blosc-1.11.1:0=
+ dev-libs/lzo:2=
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ >=sci-libs/hdf5-1.8.4:=
+"
+RDEPEND="${DEPEND}
+ >=dev-python/numexpr-2.6.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/cython-0.21[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ )
+"
+
+python_prepare_all() {
+ export {BLOSC,BZIP2,LZO,HDF5}_DIR="${ESYSROOT}"/usr
+ export PYTABLES_NO_EMBEDDED_LIBS=1
+ export USE_PKGCONFIG=TRUE
+
+ rm tables/*.c || die
+ sed -e "s:/usr:${EPREFIX}/usr:g" \
+ -i setup.py || die
+ rm -r c-blosc/{blosc,internal-complibs} || die
+ sed -i -e '/_version/ s/\\s\*/\\s\+/' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile -j1
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ "${EPYTHON}" tables/tests/test_all.py -v || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r contrib examples
+ docompress -x /usr/share/doc/${PF}/{contrib,examples}
+ fi
+}