summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 13:18:17 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 15:20:41 +0200
commit5a0cc539ffebe302ef97464c68d20ba21da4e48e (patch)
tree23a19d4dc604eb2ed762728c55bf8c3a0fd47031 /dev-python/pyte/pyte-0.5.2.ebuild
parentdev-python/contextlib2: Bump (diff)
downloadgentoo-5a0cc539ffebe302ef97464c68d20ba21da4e48e.tar.gz
gentoo-5a0cc539ffebe302ef97464c68d20ba21da4e48e.tar.bz2
gentoo-5a0cc539ffebe302ef97464c68d20ba21da4e48e.zip
dev-python/pyte: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/pyte/pyte-0.5.2.ebuild')
-rw-r--r--dev-python/pyte/pyte-0.5.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyte/pyte-0.5.2.ebuild b/dev-python/pyte/pyte-0.5.2.ebuild
new file mode 100644
index 000000000000..eabc438a4a34
--- /dev/null
+++ b/dev-python/pyte/pyte-0.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="https://pypi.python.org/pypi/pyte/ https://github.com/selectel/pyte"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test --verbose
+}