summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-27 00:21:50 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-27 00:57:48 -0600
commit6407a8ffa6f7ba5242b9719c6bb633c424d826cb (patch)
tree7f9ff88842a6fdf47f023294cf3e1588e9d0acbb /dev-python/pyte/pyte-0.8.0-r1.ebuild
parentnet-analyzer/speedtest-cli: remove old (diff)
downloadgentoo-6407a8ffa6f7ba5242b9719c6bb633c424d826cb.tar.gz
gentoo-6407a8ffa6f7ba5242b9719c6bb633c424d826cb.tar.bz2
gentoo-6407a8ffa6f7ba5242b9719c6bb633c424d826cb.zip
dev-python/pyte: add python3_7 support
Also, bump to EAPI 7 and use github tarball to fix tests. Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pyte/pyte-0.8.0-r1.ebuild')
-rw-r--r--dev-python/pyte/pyte-0.8.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyte/pyte-0.8.0-r1.ebuild b/dev-python/pyte/pyte-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..9c9700af2e52
--- /dev/null
+++ b/dev-python/pyte/pyte-0.8.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="https://pypi.org/project/pyte/ https://github.com/selectel/pyte"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+# use github tarball as pypi is missing test data
+SRC_URI="https://github.com/selectel/pyte/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # run pytest directly for tests
+ sed -i '/setup_requires=\["pytest-runner"\]/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}