summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-01 04:15:59 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-04 19:33:27 -0400
commit352645e11b5b69efa776b15d8d700e5c29429e6e (patch)
tree1ba80a6b6fb5bb34202299622af22aeba8052ef8 /dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild
parentdev-python/yarl: version bump to 1.2.4 (diff)
downloadgentoo-352645e11b5b69efa776b15d8d700e5c29429e6e.tar.gz
gentoo-352645e11b5b69efa776b15d8d700e5c29429e6e.tar.bz2
gentoo-352645e11b5b69efa776b15d8d700e5c29429e6e.zip
dev-python/pytest-aiohttp: version bump to 0.3.0
Diffstat (limited to 'dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild')
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild
new file mode 100644
index 000000000000..4c9076789a98
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-0.22.0[${PYTHON_USEDEP}]
+"