summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-20 09:05:35 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-20 10:11:06 +0100
commit3e1ecc12014f6d13a2024d20cc46cf146b423f0d (patch)
tree035f490bcfc7d005019874dc860beaa9159ae968 /dev-python/pytest-aiohttp
parentprofiles/arch/powerpc/ppc64/64le: update openjdk mask (diff)
downloadgentoo-3e1ecc12014f6d13a2024d20cc46cf146b423f0d.tar.gz
gentoo-3e1ecc12014f6d13a2024d20cc46cf146b423f0d.tar.bz2
gentoo-3e1ecc12014f6d13a2024d20cc46cf146b423f0d.zip
dev-python/pytest-aiohttp: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest1
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
index 61908e6b1a7e..0dd409f2a20a 100644
--- a/dev-python/pytest-aiohttp/Manifest
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -1 +1,2 @@
DIST pytest-aiohttp-0.3.0.tar.gz 6884 BLAKE2B 02b50fcd14192d23a4b257c2b7cb235966eff52b1c0ac87a4c61a20bc0babdb22eb999938c63e267a797d52ce57c9fb471232db3d0bc6566168a2d73f6404cd4 SHA512 4164166465dc40ff78a86304d1bcd4db9fb3f7dad3188f8ebe2ff151ed51eb0bf9c1b7a608d94cfe3339ee3b6efd4d5abbaa0691388460d5ac95635afa14984c
+DIST pytest-aiohttp-1.0.0.tar.gz 11021 BLAKE2B 9f8a3835314c4a08f90c54347b3152c1bf9ed9cfe989a8392daf164c8fef78cdfcb0a7f40691fbd3f8091eead9c06d7d1bed392ad091900b03df586742842525 SHA512 d7faddcaca9b9595ca92676c1fbe476dab7a10dff0043e86bef7c8d3c6845a79fe1bd269559038519dd8676222a803f48adc3a8b92c6e6308b7a7eb87e7e94aa
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.0.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.0.ebuild
new file mode 100644
index 000000000000..6f2f5b8373a9
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest