summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 10:02:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-13 10:29:28 +0100
commit5910231f4f92e29631bfc3c02c8ea40015b508a0 (patch)
tree869dc0d1696d0a793da922ed2a1a000170e68771 /dev-python/pytest-aiohttp
parentdev-python/typing-extensions: Bump to 4.1.0 (diff)
downloadgentoo-5910231f4f92e29631bfc3c02c8ea40015b508a0.tar.gz
gentoo-5910231f4f92e29631bfc3c02c8ea40015b508a0.tar.bz2
gentoo-5910231f4f92e29631bfc3c02c8ea40015b508a0.zip
dev-python/pytest-aiohttp: Bump to 1.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest1
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
index 3d45b191f347..f83bfdf1fb94 100644
--- a/dev-python/pytest-aiohttp/Manifest
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -1,3 +1,4 @@
DIST pytest-aiohttp-0.3.0.tar.gz 6884 BLAKE2B 02b50fcd14192d23a4b257c2b7cb235966eff52b1c0ac87a4c61a20bc0babdb22eb999938c63e267a797d52ce57c9fb471232db3d0bc6566168a2d73f6404cd4 SHA512 4164166465dc40ff78a86304d1bcd4db9fb3f7dad3188f8ebe2ff151ed51eb0bf9c1b7a608d94cfe3339ee3b6efd4d5abbaa0691388460d5ac95635afa14984c
DIST pytest-aiohttp-1.0.2.tar.gz 11102 BLAKE2B 3210b9ebb9c7e55e182595187bb17ad55acf28439750e8424004a1a33008fc62d6be26959f5d2c8db8659d9657c57e6a7b154fb1286cb6e034f26cb8c377e27c SHA512 3bab3df10ea5642c183681d2a6a70a842f1c11f0a6907334e04a528383051243cf7013548406fcc53525f9003fa536a92a45a97f7d54466a049afc4c579780e5
DIST pytest-aiohttp-1.0.3.tar.gz 11155 BLAKE2B d539b69145944458ffd18f66d92117b5cf2c3d67664660086e1f585ee089dfc85b6e605ce8c8dbe75f974c16a6ad743f46cfb1e4bc19d68e4bf04a3be65ed4fd SHA512 5d900875fd2973d7ca578d9787a6cf1e3cc6f9ae85b81e83f141c1bd2f789b55437769f2e2ebf50d424979ff4f199a73cbebd171e78f21133423476409422805
+DIST pytest-aiohttp-1.0.4.tar.gz 11868 BLAKE2B d964fe29ebe10e80391ebcbe4fc73bf37e2d8568c4d7679493ce68392b5722d75735798a78f388134d60b9c922bac116b0d453cabae5a95fc06c4288cc5d4c8e SHA512 baf87e3aa229e8a4ab6746d277a923436ad2e0625825581c94a2fb0a9bbcd309bfc55186f8866589b65a75ccfd7d5b494d71554359724c0b2c9541ea94a177d8
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
new file mode 100644
index 000000000000..6f2f5b8373a9
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest