summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-30 16:24:08 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-30 16:39:31 +0200
commit25e72763bb0b80e8fead3c85ee5adbd03fb291a9 (patch)
tree102e0a76e96454722a41e6389ca3b818b03fd089 /dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
parentkde-plasma: Drop KDE Plasma 5.16.3 (diff)
downloadgentoo-25e72763bb0b80e8fead3c85ee5adbd03fb291a9.tar.gz
gentoo-25e72763bb0b80e8fead3c85ee5adbd03fb291a9.tar.bz2
gentoo-25e72763bb0b80e8fead3c85ee5adbd03fb291a9.zip
dev-python/pytest-asyncio: New package
Add pytest-asyncio package, a test-dep of dev-python/aiohttp-socks. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild')
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
new file mode 100644
index 000000000000..ee183d8b8079
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/async_generator[${PYTHON_USEDEP}]' \
+ python3_5)"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}