summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-04 08:11:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-04 09:08:09 +0200
commit4bfb3490abcf62bbce9a3e1bdc1fe2f4ddb594f5 (patch)
treeaaa836abbbe4f9fc984654c8efd4765d7ee67233 /dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild
parentdev-python/arrow: Bump to 0.15.6 (diff)
downloadgentoo-4bfb3490abcf62bbce9a3e1bdc1fe2f4ddb594f5.tar.gz
gentoo-4bfb3490abcf62bbce9a3e1bdc1fe2f4ddb594f5.tar.bz2
gentoo-4bfb3490abcf62bbce9a3e1bdc1fe2f4ddb594f5.zip
dev-python/pytest-asyncio: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild')
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild
new file mode 100644
index 000000000000..f24ce262fa93
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0"
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}