summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-22 09:43:22 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-22 11:12:25 +0200
commite13986a5fe699f96813b6f5f76bc09de3d15cb5b (patch)
tree85471f751cc6a3c621a7ecbb4633e6ddea09f442 /dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild
parentsys-fs/btrfs-progs: amd64 stable wrt bug #618430 (diff)
downloadgentoo-e13986a5fe699f96813b6f5f76bc09de3d15cb5b.tar.gz
gentoo-e13986a5fe699f96813b6f5f76bc09de3d15cb5b.tar.bz2
gentoo-e13986a5fe699f96813b6f5f76bc09de3d15cb5b.zip
dev-python/pytest-cache: Add missing dev-python/execnet dep, #588676
Diffstat (limited to 'dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild')
-rw-r--r--dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild b/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild
new file mode 100644
index 000000000000..ecb5f90c44be
--- /dev/null
+++ b/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="mechanisms for caching across test runs"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-cache http://bitbucket.org/hpk42/pytest-cache/ http://pythonhosted.org/pytest-cache/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/execnet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+# https://bitbucket.org/hpk42/pytest-cache/issues/12
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS="pytest_cache" py.test -v -v || die
+}