summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-20 21:51:45 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-20 22:09:56 -0400
commitd3553898811c72867dfca07c5f4469fb1a94a8c1 (patch)
tree767e6b40e4379f22a4546369e1c1dbe3bd54df31 /dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild
parentdev-python/psutil: bump to 5.4.7 (diff)
downloadgentoo-d3553898811c72867dfca07c5f4469fb1a94a8c1.tar.gz
gentoo-d3553898811c72867dfca07c5f4469fb1a94a8c1.tar.bz2
gentoo-d3553898811c72867dfca07c5f4469fb1a94a8c1.zip
dev-python/pytest-cache: add python 3.7 support
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild')
-rw-r--r--dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild b/dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild
new file mode 100644
index 000000000000..2b5ca627fa72
--- /dev/null
+++ b/dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="mechanisms for caching across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-cache/
+ https://bitbucket.org/hpk42/pytest-cache/
+ https://pythonhosted.org/pytest-cache/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/execnet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+# https://bitbucket.org/hpk42/pytest-cache/issues/12
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS="pytest_cache" py.test -v -v || die
+}