summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-31 17:41:50 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-31 17:41:50 +0200
commit5de457927d685623de17c7c29fb876a41dd44f26 (patch)
tree480d4ac3abaa6db5509b704e08b3388f3e7aeaf2 /dev-python/pytest-check
parentdev-python/xlsxwriter: Remove old (diff)
downloadgentoo-5de457927d685623de17c7c29fb876a41dd44f26.tar.gz
gentoo-5de457927d685623de17c7c29fb876a41dd44f26.tar.bz2
gentoo-5de457927d685623de17c7c29fb876a41dd44f26.zip
dev-python/pytest-check: Bump to 1.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-check')
-rw-r--r--dev-python/pytest-check/Manifest1
-rw-r--r--dev-python/pytest-check/pytest-check-1.0.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-check/Manifest b/dev-python/pytest-check/Manifest
index 7cb85a73456f..00b72c7e7fed 100644
--- a/dev-python/pytest-check/Manifest
+++ b/dev-python/pytest-check/Manifest
@@ -1 +1,2 @@
DIST pytest-check-1.0.4.gh.tar.gz 7738 BLAKE2B 179575dfd4f9e50715fd5a664039fe882b0e14c9369afb6f7aca65e9ab276147b2a0b7fe580d2a249721152d891c12cedfa06ae7e26027c6b7d3b34da17d4a53 SHA512 ca71295fc5a831df295c8ce40c6a57cde9a1b98ca25354a3954fc44c9094096ea0c9c6a49139659d4c9aa4e3d3d81d80893edb657bfd3f4d988c75864e843447
+DIST pytest-check-1.0.5.gh.tar.gz 10296 BLAKE2B 8eac4185e223736181e9465c8d4220874553d9e12d068069b40e7a1ea150c93d533facc8b3483649eb00da9a2286544c58e2c530138f830155466e3bb71aeedc SHA512 73c42c98639bf3026e62f5c2c9ce404ddbd4711afa1ff31d207886329a45cfc1c0f263dd3321a9b203b9b68cad87f76bbff61894ed7a67d0bd26e7d0d20ede21
diff --git a/dev-python/pytest-check/pytest-check-1.0.5.ebuild b/dev-python/pytest-check/pytest-check-1.0.5.ebuild
new file mode 100644
index 000000000000..e1cd60cccca9
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-1.0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest_check/
+"
+SRC_URI="
+ https://github.com/okken/pytest-check/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Fix expecting result in case pytest throws deprecation warnings
+ sed -e '/fnmatch_lines/s/\* /\*/g' \
+ -e '/fnmatch_lines/s/ \*/\*/g' \
+ -i tests/test_check.py || die
+
+ distutils-r1_src_prepare
+}