summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-19 10:15:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-19 10:45:16 +0200
commitc05f58cbcc1f5a6c6a92eec2c861c9334c1bc8e1 (patch)
tree15b9405f27b0abfbab654c096d5158c6d5fc27c5 /dev-python/pytest-codeblocks
parentdev-python/git-review: Bump to 2.3.0 (diff)
downloadgentoo-c05f58cbcc1f5a6c6a92eec2c861c9334c1bc8e1.tar.gz
gentoo-c05f58cbcc1f5a6c6a92eec2c861c9334c1bc8e1.tar.bz2
gentoo-c05f58cbcc1f5a6c6a92eec2c861c9334c1bc8e1.zip
dev-python/pytest-codeblocks: Bump to 0.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-codeblocks')
-rw-r--r--dev-python/pytest-codeblocks/Manifest1
-rw-r--r--dev-python/pytest-codeblocks/pytest-codeblocks-0.15.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-codeblocks/Manifest b/dev-python/pytest-codeblocks/Manifest
index 489c4ed512c1..8ce2530eb409 100644
--- a/dev-python/pytest-codeblocks/Manifest
+++ b/dev-python/pytest-codeblocks/Manifest
@@ -1,2 +1,3 @@
DIST pytest-codeblocks-0.13.0.tar.gz 8407 BLAKE2B 5ba3c41f7b4af908172799036331c6605fcd7d9c0fb0bdfc5cf3697e97181ec099b580a30d9dcd83ed568a5ee8fe736843d26b7d39163581adeb5d75a9a321f6 SHA512 092035e5cf3d1d35fedbc6f867ff77a40751df5b4a3b922d5f960fdaa5d1ca9e599c7b813ae60a4da3cd43e3e7884f38260f77bc466e234422480b5edebee24a
DIST pytest-codeblocks-0.14.0.tar.gz 8432 BLAKE2B cb63d68e61a909bd199240470be6f09a0e48a6ef7ab4f2360940030a384919939e2274a604499bbeaf533cbf5e15b7402fd2294841ca21bc9d65c54977353549 SHA512 740b6a74a3451cee25e37969706d7b603f258c76bb8b1cd608eaf63021aaaed99136a41885b453a2708302f53e8d9516a3487dc3f5cc8ad39ca6c3ab9721ae86
+DIST pytest-codeblocks-0.15.0.tar.gz 8559 BLAKE2B 0f8cf91d333e233e480353ab55283f9d97af17e5265f7a9e6db5c7cd98aaf6075b33a44e850aad21de5112fcc233fe7f65e23710f6b1804a85fd6269d042c406 SHA512 57d14aefc0cd49aa1b8fc54dfaec47965d4b1c867cad78ba9e8fd53da85898b7eac303ac402abe10b2d63d7621979bb8bad91f66f1e264568d56f4ff70488021
diff --git a/dev-python/pytest-codeblocks/pytest-codeblocks-0.15.0.ebuild b/dev-python/pytest-codeblocks/pytest-codeblocks-0.15.0.ebuild
new file mode 100644
index 000000000000..63e1535ce48a
--- /dev/null
+++ b/dev-python/pytest-codeblocks/pytest-codeblocks-0.15.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="
+ https://github.com/nschloe/pytest-codeblocks/
+ https://pypi.org/project/pytest_codeblocks/
+"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytester
+}