summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-15 17:24:12 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-15 17:28:30 +0000
commit90fd0e8238a7cddc3391ba93b3e8dc6bf317e2c3 (patch)
treeb5fe0b29d0f78eff825acb909bb5dd5e0bffb274 /dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
parentdev-python/ipython: version bump, python-3* only (diff)
downloadgentoo-90fd0e8238a7cddc3391ba93b3e8dc6bf317e2c3.tar.gz
gentoo-90fd0e8238a7cddc3391ba93b3e8dc6bf317e2c3.tar.bz2
gentoo-90fd0e8238a7cddc3391ba93b3e8dc6bf317e2c3.zip
dev-python/pytest-cython: initial import
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/pytest-cython/pytest-cython-0.1.0.ebuild')
-rw-r--r--dev-python/pytest-cython/pytest-cython-0.1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
new file mode 100644
index 000000000000..60ca2ab4411f
--- /dev/null
+++ b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for testing Cython extension modules"
+HOMEPAGE="https://github.com/lgpage/pytest-cython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"