summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-01 16:09:39 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-01 16:12:18 -0700
commit3cdd55f461f86b922645a387bc4f0d3faa610bd8 (patch)
tree32a7f0c8eddfdfdb76e4f7eedf0dbb6be8026d6f /dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild
parentmail-client/thunderbird: fix Manifest (diff)
downloadgentoo-3cdd55f461f86b922645a387bc4f0d3faa610bd8.tar.gz
gentoo-3cdd55f461f86b922645a387bc4f0d3faa610bd8.tar.bz2
gentoo-3cdd55f461f86b922645a387bc4f0d3faa610bd8.zip
dev-python/pytest-datafiles: new package
pytest plugin to create a tmpdir containing a preconfigured set of files and/or directories Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild')
-rw-r--r--dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild b/dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild
new file mode 100644
index 000000000000..137aabf6e394
--- /dev/null
+++ b/dev-python/pytest-datafiles/pytest-datafiles-2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to create a tmpdir containing a preconfigured set of files/dirs"
+HOMEPAGE="https://github.com/omarkohl/pytest-datafiles"
+SRC_URI="https://github.com/omarkohl/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6.0[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+python_test() {
+ distutils_install_for_testing
+ PYTHONPATH="${TEST_DIR}"/lib pytest -v || die "Tests fail with ${EPYTHON}"
+}