summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-08-05 16:09:18 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-08-05 16:09:35 +0200
commite9360be7fd1b18bf2c23497c579fa301ae7bf224 (patch)
treea63911e2d13bc579f5652483aa6b848dbaf665e1 /dev-python/pytest-describe/pytest-describe-0.11.1.ebuild
parentwww-apps/kibana-bin: bump to 6.3.2 (diff)
downloadgentoo-e9360be7fd1b18bf2c23497c579fa301ae7bf224.tar.gz
gentoo-e9360be7fd1b18bf2c23497c579fa301ae7bf224.tar.bz2
gentoo-e9360be7fd1b18bf2c23497c579fa301ae7bf224.zip
dev-python/pytest-describe: disable pytest-capturelog plugin
Closes: https://bugs.gentoo.org/662820 Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-python/pytest-describe/pytest-describe-0.11.1.ebuild')
-rw-r--r--dev-python/pytest-describe/pytest-describe-0.11.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild b/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild
index 33283659c145..a875b33d9f8e 100644
--- a/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild
+++ b/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild
@@ -24,7 +24,7 @@ DEPEND="
test? ( >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}] )"
python_test() {
- # We need to disable flaky plugin because test_custom_prefix test validates
- # pytest output and output from flaky plugin would appear unexpectedly
- PYTEST_ADDOPTS="-p no:flaky" pytest -vv || die "Tests failed under ${EPYTHON}"
+ # We need to disable some plugins because tests don't like unexpected
+ # output
+ PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" pytest -vv || die "Tests failed under ${EPYTHON}"
}