summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-14 20:40:44 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-14 20:40:44 +0300
commit0797b236b532ef07827f832eebaa4f0cf930bab2 (patch)
tree224710147d8874679ca036b80deb1f823221da89 /dev-python/pytest-describe/pytest-describe-2.0.1-r1.ebuild
parentdev-python/pytest-console-scripts: enable py3.11 (diff)
downloadgentoo-0797b236b532ef07827f832eebaa4f0cf930bab2.tar.gz
gentoo-0797b236b532ef07827f832eebaa4f0cf930bab2.tar.bz2
gentoo-0797b236b532ef07827f832eebaa4f0cf930bab2.zip
dev-python/pytest-describe: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-describe/pytest-describe-2.0.1-r1.ebuild')
-rw-r--r--dev-python/pytest-describe/pytest-describe-2.0.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-describe/pytest-describe-2.0.1-r1.ebuild b/dev-python/pytest-describe/pytest-describe-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..3f2b9ad44b36
--- /dev/null
+++ b/dev-python/pytest-describe/pytest-describe-2.0.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Describe-style plugin for pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-describe/
+ https://pypi.org/project/pytest-describe/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # We need to disable some plugins because tests don't like unexpected
+ # output
+ PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" epytest
+}