summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-16 17:45:19 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-16 20:24:18 +0200
commit2250f3a16a7a19a627c05851f64768d1ad7317a0 (patch)
tree8643f8d17f70bd03918d98b073180cef8d92ca41 /dev-python/pytest-env/pytest-env-0.6.2.ebuild
parentdev-util/bazel: Bump to version 3.7.2 (diff)
downloadgentoo-2250f3a16a7a19a627c05851f64768d1ad7317a0.tar.gz
gentoo-2250f3a16a7a19a627c05851f64768d1ad7317a0.tar.bz2
gentoo-2250f3a16a7a19a627c05851f64768d1ad7317a0.zip
dev-python/pytest-env: new package
Test dependency of dev-vcs/pre-commit. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pytest-env/pytest-env-0.6.2.ebuild')
-rw-r--r--dev-python/pytest-env/pytest-env-0.6.2.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/pytest-env/pytest-env-0.6.2.ebuild b/dev-python/pytest-env/pytest-env-0.6.2.ebuild
new file mode 100644
index 000000000000..ae67df12a297
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-0.6.2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that allows you to add environment variables"
+HOMEPAGE="https://github.com/MobileDynasty/pytest-env"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"