summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-24 22:02:58 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-24 22:03:12 +0300
commit6ea224967c6f90d7729733069389af3ba8731100 (patch)
tree5b40b6cdc9b8a6254b1866014ba4619b94524862 /dev-python/pytest-env
parentdev-python/python-cstruct: add 3.3 (diff)
downloadgentoo-6ea224967c6f90d7729733069389af3ba8731100.tar.gz
gentoo-6ea224967c6f90d7729733069389af3ba8731100.tar.bz2
gentoo-6ea224967c6f90d7729733069389af3ba8731100.zip
dev-python/pytest-env: add 0.8.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-env')
-rw-r--r--dev-python/pytest-env/Manifest1
-rw-r--r--dev-python/pytest-env/pytest-env-0.8.1.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pytest-env/Manifest b/dev-python/pytest-env/Manifest
index 217812163a3a..a5869c3c45b1 100644
--- a/dev-python/pytest-env/Manifest
+++ b/dev-python/pytest-env/Manifest
@@ -1 +1,2 @@
DIST pytest-env-0.6.2.tar.gz 1693 BLAKE2B b303b8b2b486cd5f6c6273fefe709e3986183a56b6758b05f8bde973c561ebba9646538d38783749305740d8bd637966966a109fcd600cd6f6ee059449ffb328 SHA512 0b3bb21fc881023c102b584593c6e28840400ce8190810f33f9a421df4141e17dcfad2943c4159aaab82376b7b47b07b45f97c9cb232a7d17c4d35b55966596d
+DIST pytest_env-0.8.1.tar.gz 6926 BLAKE2B 1d993947c5d67a57832e170e2cc2cbe56f5f1eef37d96790ec3965e5d7b9489771d1890ef7c6f4ae504e1d6d22845cf9b1b3fccf3caeacb3e6ff33d5f86b9279 SHA512 0c99db9c5467f5fe6f8655e540fff4b91884cef3553daf455298d2dc7bb51439418f3149b941d37a777199f28d82eccb2073fdd5e09bfb97cdf24d3ddb1d21bc
diff --git a/dev-python/pytest-env/pytest-env-0.8.1.ebuild b/dev-python/pytest-env/pytest-env-0.8.1.ebuild
new file mode 100644
index 000000000000..3ab29754ad80
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-0.8.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that allows you to add environment variables"
+HOMEPAGE="https://github.com/MobileDynasty/pytest-env"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"