summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-20 22:55:39 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-21 01:12:25 -0400
commitf8bdccb1ee551de4b02f3fcb9db9fa71b7a85677 (patch)
tree4660f6631e1bc9ebec10469afc33106f06cfe8b8 /dev-python/pytest-fixture-config
parentsys-kernel/ck-sources: v.bump (4.9.51 & 4.12.14) (diff)
downloadgentoo-f8bdccb1ee551de4b02f3fcb9db9fa71b7a85677.tar.gz
gentoo-f8bdccb1ee551de4b02f3fcb9db9fa71b7a85677.tar.bz2
gentoo-f8bdccb1ee551de4b02f3fcb9db9fa71b7a85677.zip
dev-python/pytest-fixture-config: version bump to 1.2.11
Diffstat (limited to 'dev-python/pytest-fixture-config')
-rw-r--r--dev-python/pytest-fixture-config/Manifest1
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-fixture-config/Manifest b/dev-python/pytest-fixture-config/Manifest
index b8242f377f8d..97e3030bfcf4 100644
--- a/dev-python/pytest-fixture-config/Manifest
+++ b/dev-python/pytest-fixture-config/Manifest
@@ -1 +1,2 @@
+DIST pytest-fixture-config-1.2.11.tar.gz 6525 SHA256 6d4c064b614e4afbcd93b56d4ca14c44a295370e7843daf69925ff5c0fbe94a0 SHA512 9d335621c7aec41ce769f450fb618ca1611a0e97bf3bd3bdaf43bb827dde62af28fb255a36643c4e6e9c958e7f7efe3f4fc308b3129fe7625c0504c0c46f1518 WHIRLPOOL 9386794f00575efbc06fcf212f132cf11a91df942e5807ecaad7651b67298dad577a8831450ae462c185732101262278e92a208f08fd11af2d15ae3664290485
DIST pytest-fixture-config-1.2.2.tar.gz 4995 SHA256 5df71da68709a233a7a9f1aa262091ac17ddfd4c170912d07030801fd360b781 SHA512 c2d2346c50c8a73e37ce217e240eabdecf872700c9f4b020f1ca7532a06e6a5dc6b140356d96b1bf8c83f1cf737d95775abaa206c3dcf7e02555b26aa995f12d WHIRLPOOL 97488a31b1b39f5964df34900e4ff8209e425746a7791172cdc6804c98561fa73a7d28d668bbea4fa55082d81c07a50387891a60c8503eedd761bc8f9639673d
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
new file mode 100644
index 000000000000..a607d181c714
--- /dev/null
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-fixture-config"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}