summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-21 22:21:21 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-21 23:39:25 -0400
commitdc51fe278d02c417e969b00560e0fb81043127c4 (patch)
tree976b768226beb6f2c5260363fe8aa4d8a869e9c6 /dev-python/pytest-forked/pytest-forked-0.2.ebuild
parentnet-irc/unrealircd: Drop old unrealircd-4.0.6. (diff)
downloadgentoo-dc51fe278d02c417e969b00560e0fb81043127c4.tar.gz
gentoo-dc51fe278d02c417e969b00560e0fb81043127c4.tar.bz2
gentoo-dc51fe278d02c417e969b00560e0fb81043127c4.zip
dev-python/pytest-forked: initial import for newer pytest-xdist
Diffstat (limited to 'dev-python/pytest-forked/pytest-forked-0.2.ebuild')
-rw-r--r--dev-python/pytest-forked/pytest-forked-0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-forked/pytest-forked-0.2.ebuild b/dev-python/pytest-forked/pytest-forked-0.2.ebuild
new file mode 100644
index 000000000000..1416c6954209
--- /dev/null
+++ b/dev-python/pytest-forked/pytest-forked-0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="run tests in isolated forked subprocesses"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-forked https://github.com/pytest-dev/pytest-forked"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # remove bundled bytecode
+ rm -r testing/__pycache__ || die
+}
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}