summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 22:42:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 22:46:26 +0200
commit2cfc4b800f96925c16e83eee42d581aa9529b940 (patch)
treedb312fe440145d941e547ba32b4c8094dd23ffae /dev-python/pytest-forked/pytest-forked-1.1.3.ebuild
parentdev-python/sphinxcontrib-spelling: Remove old (diff)
downloadgentoo-2cfc4b800f96925c16e83eee42d581aa9529b940.tar.gz
gentoo-2cfc4b800f96925c16e83eee42d581aa9529b940.tar.bz2
gentoo-2cfc4b800f96925c16e83eee42d581aa9529b940.zip
dev-python/pytest-forked: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-forked/pytest-forked-1.1.3.ebuild')
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.1.3.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/pytest-forked/pytest-forked-1.1.3.ebuild b/dev-python/pytest-forked/pytest-forked-1.1.3.ebuild
deleted file mode 100644
index 08d46d8c9a51..000000000000
--- a/dev-python/pytest-forked/pytest-forked-1.1.3.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="run tests in isolated forked subprocesses"
-HOMEPAGE="https://pypi.org/project/pytest-forked/ https://github.com/pytest-dev/pytest-forked"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-python_test() {
- distutils_install_for_testing
- pytest -vv -p no:flaky || die "Tests failed under ${EPYTHON}"
-}