summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-03 21:24:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-03 21:24:19 +0200
commit24f6985b90b2cd8e66ba7d2039443cfc49760fc3 (patch)
tree5532ea3d46b8ba99579f0269d990f94d275746ff /dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild
parentdev-python/pytest: Remove old (diff)
downloadgentoo-24f6985b90b2cd8e66ba7d2039443cfc49760fc3.tar.gz
gentoo-24f6985b90b2cd8e66ba7d2039443cfc49760fc3.tar.bz2
gentoo-24f6985b90b2cd8e66ba7d2039443cfc49760fc3.zip
dev-python/pytest-helpers-namespace: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild')
-rw-r--r--dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild
deleted file mode 100644
index 37fea95827a4..000000000000
--- a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Provides a helpers pytest namespace"
-HOMEPAGE="https://github.com/saltstack/pytest-helpers-namespace"
-SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-BDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -r -e 's:(foo|bar):namespace_\1:g' \
- -i tests/test_helpers_namespace.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- pytest --forked -vv || die "Tests failed with ${EPYTHON}"
-}