summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-20 18:41:07 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-21 18:13:19 -0700
commit14c57c5c604f40414be3c04d8af06177ca0c3c1a (patch)
treecbc02bacf9815158923c3394d00fd2b46bb57427 /dev-python/pytest-helpers-namespace
parentdev-python/SaltTesting-2018.9.21: Version bump (diff)
downloadgentoo-14c57c5c604f40414be3c04d8af06177ca0c3c1a.tar.gz
gentoo-14c57c5c604f40414be3c04d8af06177ca0c3c1a.tar.bz2
gentoo-14c57c5c604f40414be3c04d8af06177ca0c3c1a.zip
dev-python/pytest-helpers-namespace-2019.1.8-r1: revbump, add py38, tests
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-helpers-namespace')
-rw-r--r--dev-python/pytest-helpers-namespace/Manifest2
-rw-r--r--dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild36
-rw-r--r--dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild19
3 files changed, 37 insertions, 20 deletions
diff --git a/dev-python/pytest-helpers-namespace/Manifest b/dev-python/pytest-helpers-namespace/Manifest
index 3b40f6845dea..89648fcfe50f 100644
--- a/dev-python/pytest-helpers-namespace/Manifest
+++ b/dev-python/pytest-helpers-namespace/Manifest
@@ -1 +1 @@
-DIST pytest-helpers-namespace-2019.1.8.tar.gz 5487 BLAKE2B 201e2e34f60baf95ce33f8cb5d3d8ce5465b4140e68c16f4802ba5225e28c4506c608dfc6ff4a36fddde30c7972a8c175ead976a11a731e2bfbc33e4b06cc04e SHA512 47b7f7c6638f4f3f0248722d4134b73357acb091f02cc1302d32894223d5ec06fd5382db207ae524f62749f2ebc53cf32d27eb8890d12baf250cd29dc6378a55
+DIST pytest-helpers-namespace-v2019.1.8.tar.gz 10274 BLAKE2B 1d232817e99909738f7f37466ba22fbeadf75f4fbfdd9b61790dd79418bedbce4ee219e5102ee2db1709ba991e323ce6edffc68c4e3a657c58cb628b505de098 SHA512 d5f4db3ece8b0e1719c4d1213a5e07a3c53257b089d3d74f90cf86f21a7951983a95286c7753f5e9486acc7e482d79c2a95d5a7b8eb22e19c7048db99fa3c421
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild
new file mode 100644
index 000000000000..1883af6e3263
--- /dev/null
+++ b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Provides a helpers pytest namespace"
+HOMEPAGE="https://github.com/saltstack/pytest-helpers-namespace"
+SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r -e 's:(foo|bar):namespace_\1:g' \
+ -i tests/test_helpers_namespace.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest --forked -vv || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild
deleted file mode 100644
index 5df845c7031a..000000000000
--- a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Provides a helpers pytest namespace"
-HOMEPAGE="https://github.com/saltstack/pytest-helpers-namespace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"