summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-11-28 23:05:08 -0800
committerZac Medico <zmedico@gentoo.org>2019-11-28 23:24:09 -0800
commite920ac4e5504e563593505c6f8a1a7fd12991b33 (patch)
treea6251880ffaae601e561cf85aa74f60f155ec2c1 /dev-python/pytest-html
parentdev-python/pytest-metadata: Bump to version 1.8.0 (diff)
downloadgentoo-e920ac4e5504e563593505c6f8a1a7fd12991b33.tar.gz
gentoo-e920ac4e5504e563593505c6f8a1a7fd12991b33.tar.bz2
gentoo-e920ac4e5504e563593505c6f8a1a7fd12991b33.zip
dev-python/pytest-html: Bump to version 1.22.1
Bug: https://bugs.gentoo.org/701426 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/pytest-html')
-rw-r--r--dev-python/pytest-html/Manifest1
-rw-r--r--dev-python/pytest-html/pytest-html-1.22.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-html/Manifest b/dev-python/pytest-html/Manifest
index 209db1df34eb..5c7e0284e36b 100644
--- a/dev-python/pytest-html/Manifest
+++ b/dev-python/pytest-html/Manifest
@@ -1 +1,2 @@
DIST pytest-html-1.16.0.tar.gz 23271 BLAKE2B 44ed26f5c4da0a3f03889ea7a78346bf1ebcac78a57b69e8f4027d13cb3545c673c823713bbe04f787467c5695d42723bb219fa1ebe6d2a2810313dc6b083f5e SHA512 ac79122e3cd5704d297030422181414704dd681e695ab6c71d2e569958a4b83216211064a842b11dda19d9c05689bdb39fe51d64f3d6169a305c6eac8c702afd
+DIST pytest-html-1.22.1.tar.gz 28183 BLAKE2B bf6d2aecda8fd3117a7b58307f1246e2d6f31f8939812c402d541c13dc329d7e7a0ab1f72ea70583d39614599d70dd0f4ffcc00b0d481ae4bbfce968f016adb3 SHA512 8adf1b1a27ea9f635226acdcd9d429bf78dc57ef9a67cf6616868c60b921c0cef117a63f4ef4c258350900759b607baa71d2a6b73cc8f9f718b405a7fba0d5e4
diff --git a/dev-python/pytest-html/pytest-html-1.22.1.ebuild b/dev-python/pytest-html/pytest-html-1.22.1.ebuild
new file mode 100644
index 000000000000..b7451b73e044
--- /dev/null
+++ b/dev-python/pytest-html/pytest-html-1.22.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for generating HTML reports for py.test results"
+HOMEPAGE="https://github.com/pytest-dev/pytest-html/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Lots of test failures...
+RESTRICT="test"
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-metadata[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test -v -r a testing/test_pytest_html.py || die
+}