summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-28 12:07:33 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-28 12:07:33 +0100
commit94f8b7f6c0b07277f0052e80f73ce801a8e613a8 (patch)
tree2ded5c5c2077cc863ee57088eeb57829d29f4127 /dev-python/pytest-httpbin
parentmedia-video/popcorntime-bin: fix QA_PREBUILT (diff)
downloadgentoo-94f8b7f6c0b07277f0052e80f73ce801a8e613a8.tar.gz
gentoo-94f8b7f6c0b07277f0052e80f73ce801a8e613a8.tar.bz2
gentoo-94f8b7f6c0b07277f0052e80f73ce801a8e613a8.zip
dev-python/pytest-httpbin: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest1
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-1.0.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
index 43084e956131..7e7f2a27648f 100644
--- a/dev-python/pytest-httpbin/Manifest
+++ b/dev-python/pytest-httpbin/Manifest
@@ -1 +1,2 @@
DIST pytest-httpbin-1.0.0.gh.tar.gz 17813 BLAKE2B b7e0ad9f131e4d236161b66b1d6d8e6087285a6d52df1accb044b30bcdac6c5f3350e9dbfe1cf33ab64b6d6aac6b463de81c31fd12dd950426b6ed8ef4eaf289 SHA512 2794134cc005cb969752e0c1119459d3f1e106f679942880a6b9ff507f2ee31c8ac4146a9c01b9a920368ea516443954b1b7044f7b1c270fe251f7d36adf7661
+DIST pytest-httpbin-1.0.1.gh.tar.gz 18036 BLAKE2B 1277118a83d059f23c06758d6a5e83b78f09ba3bd44458f18aebdad06b7266a3deb9ee00f10732c552fddb42673dfe3f5862195f44ce48a224961b5df81dcae7 SHA512 3a11073d85478e7b748cfae5a7f639b2cf6ebc396ebb9972f39ead3d869ab1abaf0afa90f113e2393652ed08621716e54c9c5dcb41c59ff67341f7b28445544d
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-1.0.1.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-1.0.1.ebuild
new file mode 100644
index 000000000000..1413b57ca6d2
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="https://github.com/kevin1024/pytest-httpbin
+ https://pypi.org/project/pytest-httpbin/"
+SRC_URI="https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/requests[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/pytest-httpbin-1.0.0-pypy3-hang.patch
+)
+
+distutils_enable_tests pytest