summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:13:58 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:13:58 -0400
commitf1b57cb8b2995eff632e8d9caee5d3082c9dfa32 (patch)
tree9535ce444777522318771ac6bcdc673fa1673e3f /dev-python/pytest-isort/pytest-isort-0.1.0.ebuild
parentInitial commit. Required by weasyprint. (diff)
downloadgentoo-f1b57cb8b2995eff632e8d9caee5d3082c9dfa32.tar.gz
gentoo-f1b57cb8b2995eff632e8d9caee5d3082c9dfa32.tar.bz2
gentoo-f1b57cb8b2995eff632e8d9caee5d3082c9dfa32.zip
dev-python/pytest-isort: Initial commit
Required by weasyprint. Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-python/pytest-isort/pytest-isort-0.1.0.ebuild')
-rw-r--r--dev-python/pytest-isort/pytest-isort-0.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-isort/pytest-isort-0.1.0.ebuild b/dev-python/pytest-isort/pytest-isort-0.1.0.ebuild
new file mode 100644
index 000000000000..d0c9bc036a4d
--- /dev/null
+++ b/dev-python/pytest-isort/pytest-isort-0.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for isort"
+HOMEPAGE="https://github.com/moccu/${PN} https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/isort-3.9.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cache-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"