summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-20 14:26:32 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-20 18:02:30 -0800
commitdfcb4897e23b574eaf7c3f5881980f015246226c (patch)
treedd764f4cf07b22d82326e7442ffc0d2b9d7744f4 /dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
parentdev-python/process-tests: Version bump to 2.0.2 (diff)
downloadgentoo-dfcb4897e23b574eaf7c3f5881980f015246226c.tar.gz
gentoo-dfcb4897e23b574eaf7c3f5881980f015246226c.tar.bz2
gentoo-dfcb4897e23b574eaf7c3f5881980f015246226c.zip
dev-python/pytest-localserver: Version bump to 0.5.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild')
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
new file mode 100644
index 000000000000..3a496a86392d
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{5,6,7}} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Py.test plugin to test server connections locally"
+HOMEPAGE="https://pypi.org/project/pytest-localserver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest