summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2018-06-07 07:57:36 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-07 12:52:29 +0200
commitabe7cb7c223048fc07d4056bb53c280e25ea216a (patch)
tree3e49135a5e02ad5d1785cee609befdd93ff83496 /dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild
parentdev-util/schroot: Switch to https (diff)
downloadgentoo-abe7cb7c223048fc07d4056bb53c280e25ea216a.tar.gz
gentoo-abe7cb7c223048fc07d4056bb53c280e25ea216a.tar.bz2
gentoo-abe7cb7c223048fc07d4056bb53c280e25ea216a.zip
dev-python/pytest-metadata: Bump to v1.7.0 and update metadata
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8742
Diffstat (limited to 'dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild')
-rw-r--r--dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild b/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild
new file mode 100644
index 000000000000..30042a6adbdf
--- /dev/null
+++ b/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for pytest that provides access to test session metadata"
+HOMEPAGE="https://github.com/davehunt/pytest-metadata/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+python_test() {
+ py.test || die
+}