summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-15 20:48:44 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-15 20:48:44 +0300
commit832e67f6c8f215aeac0c9b29bb096a6ca06f1ced (patch)
tree8ec0d64836701da3017a14a07692356cf4e325d5 /dev-python/pytest-metadata
parentx11-plugins/wmhdplop/files: merge old cflags patch in current patch (diff)
downloadgentoo-832e67f6c8f215aeac0c9b29bb096a6ca06f1ced.tar.gz
gentoo-832e67f6c8f215aeac0c9b29bb096a6ca06f1ced.tar.bz2
gentoo-832e67f6c8f215aeac0c9b29bb096a6ca06f1ced.zip
dev-python/pytest-metadata: add 2.0.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-metadata')
-rw-r--r--dev-python/pytest-metadata/Manifest1
-rw-r--r--dev-python/pytest-metadata/pytest-metadata-2.0.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-metadata/Manifest b/dev-python/pytest-metadata/Manifest
index b68f6ba06d15..0d15cdb9c0c1 100644
--- a/dev-python/pytest-metadata/Manifest
+++ b/dev-python/pytest-metadata/Manifest
@@ -1 +1,2 @@
DIST pytest-metadata-2.0.1.gh.tar.gz 19945 BLAKE2B 931ede3b58471e3092eb26af38f380810140539c7c50b5e3e9a63bdddedd9577b1f23aafb24ce80de55078f772b0dae8715368559f79a3f31f33e15870134f45 SHA512 03981b4fbcd812cf5896d6db2b74cbc1e6c84cc13613f916248767cacfc7650580f668a5ea8892be85c87fa08101a8a2f440ee6e0cc1342d4fa9919d41153a6b
+DIST pytest-metadata-2.0.2.gh.tar.gz 19993 BLAKE2B 274ce5532fe96b6e4116d6ed1bf20911342f8b239b00a9b6cc1b553ad2819a619691e34bd93ef82676ffdcd4ba32adebba481c65168ce76eef2099eb7295d65d SHA512 b35c0b1a357a246aa12b65dd67b48b6c4201d75d4a23db9026659407583e97517971ba6af1054cff7812f2c6ae54019b26d1108664d632a45c0514a716b321b2
diff --git a/dev-python/pytest-metadata/pytest-metadata-2.0.2.ebuild b/dev-python/pytest-metadata/pytest-metadata-2.0.2.ebuild
new file mode 100644
index 000000000000..3f2c81106531
--- /dev/null
+++ b/dev-python/pytest-metadata/pytest-metadata-2.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for pytest that provides access to test session metadata"
+HOMEPAGE="https://github.com/pytest-dev/pytest-metadata/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-metadata/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}