summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-10-29 14:28:52 -0700
committerZac Medico <zmedico@gentoo.org>2017-10-29 15:13:05 -0700
commit81eab3df3f1dfad84b1155d7598da8fbf991e3d4 (patch)
tree4e0bdb97f7878efdf6c1a3673a6e1800a988f5bc /dev-python/pytest-mock/pytest-mock-1.5.0.ebuild
parentnet-libs/webkit-gtk: security cleanup (diff)
downloadgentoo-81eab3df3f1dfad84b1155d7598da8fbf991e3d4.tar.gz
gentoo-81eab3df3f1dfad84b1155d7598da8fbf991e3d4.tar.bz2
gentoo-81eab3df3f1dfad84b1155d7598da8fbf991e3d4.zip
dev-python/pytest-mock: remove old versions
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/pytest-mock/pytest-mock-1.5.0.ebuild')
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.5.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-1.5.0.ebuild b/dev-python/pytest-mock/pytest-mock-1.5.0.ebuild
deleted file mode 100644
index 32941be25b3c..000000000000
--- a/dev-python/pytest-mock/pytest-mock-1.5.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
-HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
- python_targets_python2_7? (
- dev-python/mock[python_targets_python2_7]
- )
- python_targets_pypy? (
- dev-python/mock[python_targets_pypy]
- )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-src_prepare() {
- if has_version dev-python/mock; then
- # test fails when standalone mock is installed
- sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i test_pytest_mock.py || die
- fi
- distutils-r1_src_prepare
-}
-
-python_test() {
- PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
- py.test test_pytest_mock.py || die
-}