summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-23 19:40:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-23 19:44:15 +0300
commita4070a13d3701c0688edde718c186b6c2f8750b0 (patch)
tree55bdde45ff2a152400c98a39d9ca40976cf52670 /dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
parentmedia-sound/pulseaudio: ebuild touchups (diff)
downloadgentoo-a4070a13d3701c0688edde718c186b6c2f8750b0.tar.gz
gentoo-a4070a13d3701c0688edde718c186b6c2f8750b0.tar.bz2
gentoo-a4070a13d3701c0688edde718c186b6c2f8750b0.zip
dev-python/pytest-ordering: enable py3.10, fix for >=pytest-6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-ordering/pytest-ordering-0.6.ebuild')
-rw-r--r--dev-python/pytest-ordering/pytest-ordering-0.6.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
index 0bd6f7293be1..25ef67eebc14 100644
--- a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
+++ b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -18,7 +18,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 sparc x86"
-RDEPEND="<dev-python/pytest-6[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-pytest-6.patch"
+)
distutils_enable_tests --install pytest
distutils_enable_sphinx docs/source