summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-13 16:28:53 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-15 11:57:51 -0400
commit916a8b2f95d9f7c599d812fea4731ec59df7bf22 (patch)
tree7fe7042af6f238835faf7f9cae0f35dcb72c023a /dev-python/pytest-pep8
parentdev-python/pytest-pep8: Python 3.7 compatibility (diff)
downloadgentoo-916a8b2f95d9f7c599d812fea4731ec59df7bf22.tar.gz
gentoo-916a8b2f95d9f7c599d812fea4731ec59df7bf22.tar.bz2
gentoo-916a8b2f95d9f7c599d812fea4731ec59df7bf22.zip
dev-python/pytest-pep8: EAPI=7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-python/pytest-pep8')
-rw-r--r--dev-python/pytest-pep8/pytest-pep8-1.0.6-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-pep8/pytest-pep8-1.0.6-r1.ebuild b/dev-python/pytest-pep8/pytest-pep8-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..bdf4a19b0b68
--- /dev/null
+++ b/dev-python/pytest-pep8/pytest-pep8-1.0.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check PEP8 requirements"
+HOMEPAGE="https://pypi.org/project/pytest-pep8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/1.0.6-MANIFEST.patch
+)
+
+python_test() {
+ ${EPYTHON} test_pep8.py || die
+}