summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-01 12:55:44 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-23 11:53:19 +0200
commitf3b96f90554a4b5fb85ad9e6cccf577dbbad6b70 (patch)
tree847fc60e00b5e73d8a86e094a0106b4cc731209f /dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
parentdev-python/qtawesome: Version bump 0.6.1 (diff)
downloadgentoo-f3b96f90554a4b5fb85ad9e6cccf577dbbad6b70.tar.gz
gentoo-f3b96f90554a4b5fb85ad9e6cccf577dbbad6b70.tar.bz2
gentoo-f3b96f90554a4b5fb85ad9e6cccf577dbbad6b70.zip
dev-python/pytest-qt: pytest plugin for Qt (PyQt4, PyQt5 and PySide)
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Package-Manager: Portage-2.3.84, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/14007 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pytest-qt/pytest-qt-3.3.0.ebuild')
-rw-r--r--dev-python/pytest-qt/pytest-qt-3.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
new file mode 100644
index 000000000000..4f2d4bd24bac
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="pytest plugin for PyQt4 or PyQt5 applications"
+HOMEPAGE="https://pypi.org/project/pytest-qt https://github.com/pytest-dev/pytest-qt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-skip-show-window-test.patch" )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_test() {
+ pytest_qt_test() {
+ # pytest-qt test fail to test in ${BUILDIR}/lib
+ # if and only if pytest-qt is not already installed
+ # test do work if executed directly in the extracted tarball
+ local PYTHONPATH="${WORKDIR}/${P}"
+ pytest -vv
+ }
+
+ virtx pytest_qt_test
+}