summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-24 22:22:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-24 22:22:05 +0200
commit1f1d624a5db3af245d1967d2871deeb958d11824 (patch)
tree7047655f49b678054f89f351e0f0f072fc918aec /dev-python/pytest-qt
parentdev-python/paste: Remove old (diff)
downloadgentoo-1f1d624a5db3af245d1967d2871deeb958d11824.tar.gz
gentoo-1f1d624a5db3af245d1967d2871deeb958d11824.tar.bz2
gentoo-1f1d624a5db3af245d1967d2871deeb958d11824.zip
dev-python/pytest-qt: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest1
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.0.2-r1.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index b2b6f18692fd..794f27a65f05 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,2 +1 @@
-DIST pytest-qt-4.0.2.tar.gz 113466 BLAKE2B 73ba6571958f3f4cd76c3e891eaa014d464b94a7965afac6cee5b43bafdc63d4d640f84c7bfa1666146ab5139f79c760bd9f5a2a44f788b6384df200ac48ad0d SHA512 7f59c499e1395460c2ff20a969cec16ca104f742c648faa0d7eb1528c04d8ee52c04c52798478bc01c5467bee33d3389b141424491ba5442f9df4e82f0dff173
DIST pytest-qt-4.1.0.tar.gz 119702 BLAKE2B 7c906c94761df6472ae65a6ebb38dff07de8156730e3e10615ea8e08f0bd9f9fee07127ee6e8616055117b1db1911bc9b4486345d84b249664d317561195ad77 SHA512 bfb56abbaac47bf9da26eb19d6913d59872f2a9923da339e9a30a2145d0a094ddec36bcfa21d39c4cf318f95a83c72c249fe70034294a6791f9d84345f77451d
diff --git a/dev-python/pytest-qt/pytest-qt-4.0.2-r1.ebuild b/dev-python/pytest-qt/pytest-qt-4.0.2-r1.ebuild
deleted file mode 100644
index cddbe0810ddd..000000000000
--- a/dev-python/pytest-qt/pytest-qt-4.0.2-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Pytest plugin for PyQt5 and PySide2 applications"
-HOMEPAGE="
- https://pypi.org/project/pytest-qt/
- https://github.com/pytest-dev/pytest-qt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-RDEPEND="dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
- ' python3_{8..10} )
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- # warnings from other plugins cause the test output matchers to fail
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytestqt.plugin
-
- local EPYTEST_DESELECT=(
- # requires the window to be activated; that doesn't seem
- # to be possible inside Xvfb
- "tests/test_basics.py::test_wait_window[waitActive-True]"
-
- # we are forcing a specific module via envvar, effectively
- # overriding the config
- tests/test_basics.py::test_qt_api_ini_config
- tests/test_basics.py::test_qt_api_ini_config_with_envvar
- )
-
- PYTEST_QT_API="pyqt5" epytest || die
- # Pyside2 is not compatible with python3.11
- if [[ "${EPYTHON}" != python3.11 ]]; then
- PYTEST_QT_API="pyside2" epytest || die
- fi
-}