summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-15 16:28:53 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-15 16:28:53 -0500
commit706f04a56209e8370a385cab801be1f1d6005f76 (patch)
tree5d67ae97da34abfa5cdba0ab99b2b6b22c1ad57f /dev-python/pytest-qt
parentsys-kernel/ck-sources: bugfix / revbump (4.9.76-r1) (diff)
downloadgentoo-706f04a56209e8370a385cab801be1f1d6005f76.tar.gz
gentoo-706f04a56209e8370a385cab801be1f1d6005f76.tar.bz2
gentoo-706f04a56209e8370a385cab801be1f1d6005f76.zip
dev-python/pytest-qt: drop PyQt4, properly depend on PyQt5[gui], bug #644682
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0-r1.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..cbbfd24fc3d7
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-2.3.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for PyQt4 or PyQt5 applications"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-qt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytest-2.7.0[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Test make assumptions about Qt environment
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}