summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-25 11:39:14 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-25 11:43:18 +0200
commit73ae489c380e26c507c3239ee6ce6cc7ac9bb622 (patch)
tree554ca61c2b461b1e2d9ab2c0e044be016faaa0cb /dev-python/pytest-qt
parentdev-python/spyder: unrestrict pytest-qt dep (diff)
downloadgentoo-73ae489c380e26c507c3239ee6ce6cc7ac9bb622.tar.gz
gentoo-73ae489c380e26c507c3239ee6ce6cc7ac9bb622.tar.bz2
gentoo-73ae489c380e26c507c3239ee6ce6cc7ac9bb622.zip
dev-python/pytest-qt: drop 3.3.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest1
-rw-r--r--dev-python/pytest-qt/pytest-qt-3.3.0.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index f14eaa57756e..82b75962d056 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,2 +1 @@
-DIST pytest-qt-3.3.0.tar.gz 113439 BLAKE2B 1eb486d2d44825058577306ed3b9ade34e6cbad0d90038fe314114bb22c82ae069c9fe66c170591de6c97bad99f5f9e0021c8b3dc38c858b8293a22c448bed74 SHA512 8b3ce7b62621c55fb319966b162cb60663c5ef290f34e62e6a9329e67f530c2bde1329ae0b045b15c99ae14f5f6a5fef9ee930475fa700922c50ee725adf7983
DIST pytest-qt-4.0.2.tar.gz 113466 BLAKE2B 73ba6571958f3f4cd76c3e891eaa014d464b94a7965afac6cee5b43bafdc63d4d640f84c7bfa1666146ab5139f79c760bd9f5a2a44f788b6384df200ac48ad0d SHA512 7f59c499e1395460c2ff20a969cec16ca104f742c648faa0d7eb1528c04d8ee52c04c52798478bc01c5467bee33d3389b141424491ba5442f9df4e82f0dff173
diff --git a/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
deleted file mode 100644
index 8e4e3f6611c2..000000000000
--- a/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="pytest plugin for PyQt5 and PySide2 applications"
-HOMEPAGE="
- https://pypi.org/project/pytest-qt/
- https://github.com/pytest-dev/pytest-qt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
- ' python3_{7..9} )
- )
-"
-
-# Patch 1 skips a test that does not work inside the emerge environment:
-# pytestqt.exceptions.TimeoutError: widget <PyQt5.QtWidgets.QWidget object at 0x7f57d8527af8> not activated in 1000 ms.
-# Patch 2 fixes upstream bug 314
-PATCHES=(
- "${FILESDIR}/${P}-skip-show-window-test.patch"
- "${FILESDIR}/${P}-fix-file-match-test.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- # This is not going to work since we want to test both implementations
- # and therefore pull in both and explicitly set PYTEST_QT_API
- sed -i -e 's:test_qt_api_ini_config_with_envvar:_&:' \
- -e 's:test_qt_api_ini_config:_&:' \
- tests/test_basics.py || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- virtx python_foreach_impl python_test
-}
-
-python_test() {
- distutils_install_for_testing
- PYTEST_QT_API="pyqt5" epytest
- if [[ "${EPYTHON}" == "python3.10" ]]; then
- return
- else
- PYTEST_QT_API="pyside2" epytest
- fi
-}