summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-25 12:48:06 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-08 21:15:19 +0200
commitf29c6b993b40bc4621294a5ca8ed781b5f8a279c (patch)
tree6756532a6d820e2916d05899a09e6cba86f4506d /dev-python/pytest-qt
parentdev-python/QtPy: enable py3.11 (diff)
downloadgentoo-f29c6b993b40bc4621294a5ca8ed781b5f8a279c.tar.gz
gentoo-f29c6b993b40bc4621294a5ca8ed781b5f8a279c.tar.bz2
gentoo-f29c6b993b40bc4621294a5ca8ed781b5f8a279c.zip
dev-python/pytest-qt: enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.0.2-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/pytest-qt/pytest-qt-4.0.2-r1.ebuild b/dev-python/pytest-qt/pytest-qt-4.0.2-r1.ebuild
index 11a6bd58b0a3..cddbe0810ddd 100644
--- a/dev-python/pytest-qt/pytest-qt-4.0.2-r1.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-4.0.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1 virtualx
@@ -22,7 +22,9 @@ RDEPEND="dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
- dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
+ ' python3_{8..10} )
)
"
@@ -50,5 +52,8 @@ python_test() {
)
PYTEST_QT_API="pyqt5" epytest || die
- PYTEST_QT_API="pyside2" epytest || die
+ # Pyside2 is not compatible with python3.11
+ if [[ "${EPYTHON}" != python3.11 ]]; then
+ PYTEST_QT_API="pyside2" epytest || die
+ fi
}